Active Issue Alert – Blackbaud Payment Service - 000439575
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored as of 11:30 AM EST, 03/12/2023. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 12, 2023 - 11:35 EDT
Update
We are aware of an issue where card-not-present transactions will fail when processing with Experian. Engineers are working to resolve the issue as quickly as possible. Please continue to reference this page for updates.
Posted Mar 12, 2023 - 10:10 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 12, 2023 - 09:59 EDT
This incident affected: Payment Services.