Active Issue Alert – Blackbaud CRM - #000237803
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Mar 29, 2021 - 20:04 EDT
Identified
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Mar 29, 2021 - 19:25 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 29, 2021 - 18:50 EDT
This incident affected: Blackbaud CRM™.