Active Issue Alert – Blackbaud Financial Aid Management (formerly Blackbaud Smart Aid) - #2019030601
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Mar 06, 2019 - 11:09 EST
Identified
Our engineers have successfully diagnosed the issue and are working to deploy a fix as soon as possible. While sites and applications are not working within Internet Explorer they are working correctly in all other browsers. We hope to have your full service restored as quickly as possible. Please continue to reference this page for updates. Next update will be at 12 EST.
Posted Mar 06, 2019 - 10:56 EST
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Mar 06, 2019 - 10:11 EST
This incident affected: Blackbaud Financial Aid Management™.