Active Issue Alert – Blackbaud.com, Multiple Services - 000413649
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Dec 05, 2022 - 16:23 EST
Monitoring
Our engineers have successfully diagnosed and mitigated the issue. We will continue to monitor the performance of our systems to ensure there is no further impact to our services. Please continue to reference this page for updates.
Posted Dec 05, 2022 - 13:28 EST
Identified
Our engineers have successfully diagnosed the issue and we have the appropriate engineers available working to address it for you. The effects of this issue have been mitigated at this time and we hope to have your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Dec 05, 2022 - 11:14 EST
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause and we have the appropriate engineers working to get your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Dec 05, 2022 - 10:38 EST
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud Fundraiser Performance Management™ (Blackbaud Fundraiser Performance Management™), Blackbaud Altru®, Blackbaud Guided Fundraising™, Blackbaud Tuition Management™, Email Services, Payment Services, ResearchPoint™, Blackbaud Financial Edge NXT® (Financial Edge NXT), Blackbaud Education Management Solutions (Core Functionality), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).