Resolved Issue Alert – Blackbaud NetCommunity & Online Express - #2018011801
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing delays in the delivery of emails is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 18, 2018 - 06:33 EST