Active Issue Alert – Altru, Research Point - #000182729
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 23, 2020 - 19:27 EDT
Identified
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Oct 23, 2020 - 19:13 EDT
This incident affected: Blackbaud Altru® and ResearchPoint™.