Active Issue Alert – Financial Edge, Financial Edge NXT, Raiser's Edge, Education Edge - #2019052003
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted May 20, 2019 - 14:44 EDT
Update
We are continuing to investigate this issue.
Posted May 20, 2019 - 14:26 EDT
Investigating
We have identified an issue impacting some of our Financial Edge and Financial Edge NXT customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted May 20, 2019 - 14:17 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT) and Financial Edge®.