Maintenance Overage 21051402253538 - Altru
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Aug 04, 2021 - 03:20 EDT
Identified
Maintenance ID 21051402253538- The maintenance that was scheduled to complete on 08/04/2021 at 03:00 am est has been extended to 08/04/2021 at 05:00 am est.

Please refer to this page for updates on the completion or additional extensions of the maintenance. This maintenance is necessary to perform an update in our environment.
Posted Aug 04, 2021 - 03:06 EDT
This incident affected: Blackbaud Altru®.