Active Issue Alert – Blackbaud Merchant Services - #2018011901
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers attempting to provision brand new Merchant Services accounts is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 19, 2018 - 11:03 EST
Identified
We are aware of an issue affecting customers attempting to provision brand new Merchant Services accounts. Our engineers have successfully diagnosed the issue, and we are working to address it now. This issue only effects new client signups; Payment processing for existing clients is fully functional. Please continue to reference this page for updates.
Posted Jan 19, 2018 - 10:36 EST
Investigating
We are aware that some of our Payment Services or Merchant Services customers are experiencing an issue attempting to provision brand new Merchant Services accounts. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jan 19, 2018 - 10:13 EST