Active Issue Alert – Blackbaud CRM - 2018041902
Incident Report for Blackbaud
Resolved
An issue impacting a small subset of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. Please note that jobs may extra time to complete. If you have any questions about status in the future, you can always get updates at this page. Thank you
Posted Apr 19, 2018 - 17:16 EDT
Monitoring
An issue impacting a small subset of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. Please note that jobs may extra time to complete. We are currently monitoring for further issues. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 19, 2018 - 15:46 EDT
Identified
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Apr 19, 2018 - 15:23 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Apr 19, 2018 - 14:56 EDT
This incident affected: Blackbaud CRM™.