Active Issue Alert – Blackbaud CRM, Education Edge, Financial Edge, Raiser's Edge - #2018101503
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Oct 15, 2018 - 16:15 EDT
Identified
After initial restoration of service, we have identified an issue in which a small subset of customers may receive stale data if trying to run reports. We have identified a fix however it will take time to implement. Please note that once implemented you may experience up to five minutes of intermittent connectivity if using CRM applications or file share services for Education Edge, Financial Edge, and Raiser's Edge. We are working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Oct 15, 2018 - 15:56 EDT
Monitoring
An issue impacting some of our customers is now resolved and services have been restored. We are currently monitoring for further issues. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 15, 2018 - 15:27 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Oct 15, 2018 - 15:22 EDT
This incident affected: Blackbaud CRM™, Financial Edge®, and Raiser's Edge®.