Active Issue Alert – Blackbaud Merchant Services - #000146437
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jul 06, 2020 - 10:41 EDT
Update
We have identified an issue impacting some of our customers causing transactions to be missing in disbursement report. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 06, 2020 - 10:34 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 06, 2020 - 10:11 EDT
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™).