Active Issue Alert – Education Edge, Financial Edge, Raiser's Edge - #2019090301
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted 18 days ago. Sep 03, 2019 - 11:20 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted 18 days ago. Sep 03, 2019 - 10:43 EDT
This incident affected: Education Edge (Education Edge) and Financial Edge, Raiser's Edge.