Active Issue Alert – Blackbaud Payment Service - #000353690
Incident Report for Blackbaud
Resolved
This incident has been resolved. Service impact ended as of 16:10 EST. We are still working with the vendor to ensure we obtain batch results.
Posted May 13, 2022 - 00:45 EDT
Update
We have identified an issue impacting a subset of Blackbaud Payment Service customers when processing batch transactions. Batches may result in the error: "Error encountered while checking batch status."

Please do not reprocess the batches to prevent duplicates.

The batches have processed and we are working with the vendor to resolve it for you as quickly as possible and obtain batch results. Please continue to reference this page for updates.

The next update will be at 9:00 AM ET.
Posted May 12, 2022 - 18:00 EDT
Update
We have identified an issue impacting a subset of Blackbaud Payment Service customers when processing batch transactions. Batches may result in the error: "Error encountered while checking batch status."

Please do not reprocess the batches to prevent duplicates.

The batches have processed and we are working with the vendor to resolve it for you as quickly as possible and obtain batch results. Please continue to reference this page for updates.
Posted May 12, 2022 - 14:22 EDT
Identified
Our engineers have successfully diagnosed the issue and we have the appropriate engineers available working to address it for you. We hope to have your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted May 12, 2022 - 12:48 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted May 12, 2022 - 11:53 EDT
This incident affected: Payment Services.