Maintenance Overage – Financial Edge, Raisers Edge, Blackbaud Church Management - RFC #20091405492465
Incident Report for Blackbaud
Resolved
The RFC has now been completed successfully. We apologize for any trouble this may have caused.
Posted Oct 17, 2020 - 17:56 EDT
Investigating
We are currently experiencing an overage concerning RFC#20091405492465. Our engineers are working to complete this work for you as quickly as possible. Please continue to reference this page for updates.
Posted Oct 17, 2020 - 16:54 EDT
This incident affected: Financial Edge® and Raiser's Edge®.