Maintenance Overage 03024 - Financial Edge / Education Edge
Incident Report for Blackbaud
Resolved
The scheduled maintenance has been completed.
Posted Jan 10, 2020 - 01:30 EST
Identified
Maintenance ID 19121012003024 - The maintenance that was scheduled to complete on 01/10/2020 at 12:00:00 AM EST has been extended to 2:00:00 AM EST.
This maintenance is necessary to upgrade Financial Edge-Education Edge to the latest version 7.87 Patch 33.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Jan 10, 2020 - 00:05 EST
This incident affected: Financial Edge®.