Maintenance Overage Blackbaud Education Management Solutions- #000180475
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 18, 2020 - 19:12 EDT
Investigating
We are currently experiencing an overage concerning Incident#000180475. Our engineers are working to complete this work for you as quickly as possible. Please continue to reference this page for updates.
Posted Oct 18, 2020 - 13:56 EDT
This incident affected: Blackbaud Education Management Solutions (Blackbaud School Website System™, Blackbaud Enrollment Management System™, Blackbaud Learning Management System, Blackbaud Student Information System™, Core Functionality, School API, Blackbaud Billing Management™).