Resolved Issue Alert – Sphere - #2018101701
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 17, 2018 - 03:12 EDT