Maintenance Overage 22051306170038 - ResearchPoint
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted May 20, 2022 - 04:50 EDT
Identified
Maintenance ID 22051306170038 - The maintenance that was scheduled to complete on 05/20/2022 at 03:00 AM EST has been extended to 05:00 AM EST.
This maintenance is necessary to perform an update in our environment.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted May 20, 2022 - 03:16 EDT
This incident affected: ResearchPoint™.