Resolved Issue Alert – Financial Edge NXT - #2019041201
Incident Report for Blackbaud
Resolved
We identified an issue impacting a subset of our Financial Edge NXT customers causing intermittent slowness, errors or other service issues .

Our engineers have successfully implemented a fix and services are now restored. If you have any questions about status in the future, you can always get updates at this page.

Please continue to reference this page for updates.
Posted Apr 12, 2019 - 17:48 EDT
This incident affected: Blackbaud Financial Edge NXT® (Accounts Payable API, Financial Edge NXT, General Ledger API, Statistical Unit API, Treasury API).