Active Issue Alert – Raiser's Edge - 20191125
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Nov 25, 2019 - 05:38 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 25, 2019 - 05:28 EST
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Nov 25, 2019 - 04:20 EST
This incident affected: Raiser's Edge.