Active Issue Alert – Blackbaud Payment Service, Blackbaud CRM and Blackbaud NetCommunity – #2018021101
Incident Report for Blackbaud
Resolved
An issue impacting some of our Blackbaud CRM and Blackbaud NetCommunity customers are having issues accessing Payment Services is now resolved. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Feb 12, 2018 - 20:20 EST
Update
As reported, we are aware that a small subset of our Blackbaud CRM and Blackbaud NetCommunity customers are having issues accessing Payment Services. Our engineers have successfully diagnosed the issue, and are continuing to address it now. Please continue to reference this page for updates. We will provide additional updates in 1 hour.
Posted Feb 12, 2018 - 19:10 EST
Update
As reported, we are aware that a small subset of our Blackbaud CRM and Blackbaud NetCommunity customers are having issues accessing Payment Services. Our engineers have successfully diagnosed the issue, and are continuing to address it now. Please continue to reference this page for updates.
Posted Feb 12, 2018 - 18:41 EST
Identified
We are aware that a small subset of our Blackbaud CRM and Blackbaud NetCommunity customers are having issues accessing Payment Services. Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Feb 12, 2018 - 17:55 EST
Investigating
We are aware that a small subset of our Blackbaud CRM customers are having issues accessing Payment Services. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 12, 2018 - 17:44 EST
This incident affected: Blackbaud CRM™, Blackbaud NetCommunity™, and Payment Services.