Active Issue Alert – Blackbaud Employee Giving, Blackbaud Employee Volunteering - #2019051401
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted May 14, 2019 - 17:05 EDT
Monitoring
We have identified an issue impacting some of our Blackbaud Employee Giving and Blackbaud Employee Volunteering customers. Our engineers have taken remediation steps and we are seeing improvement in the responsiveness and availability of the application. We will monitor for the next 10 minutes. Please continue to reference this page for updates.
Posted May 14, 2019 - 16:58 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted May 14, 2019 - 16:13 EDT