Active Issue Alert – Blackbaud Tuition Management - #000146407
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jul 06, 2020 - 10:38 EDT
Investigating
We are currently experiencing an issue with Parent chat support for Smart Tuition and Smart Aid.
Posted Jul 06, 2020 - 09:16 EDT
This incident affected: Blackbaud Tuition Management™.