Active Issue Alert – Blackbaud.com, Multiple Products - 000416694
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Dec 08, 2022 - 09:50 EST
Monitoring
The affected services are back online. We will continue to monitor the performance of our systems to ensure there is no further impact to our services. Please continue to reference this page for updates.
Posted Dec 07, 2022 - 12:19 EST
Update
We are aware of issues impacting users' ability to log in to blackbaud.com and various solutions. Users may see Error: "Our services aren't available right now," or a continual loading screen. Engineers are working to resolve the issues as quickly as possible.
Posted Dec 07, 2022 - 11:20 EST
Update
We are aware of issues impacting users' ability to log in to blackbaud.com and various solutions. Users may see Error: "Our services aren't available right now," or a continual loading screen. Engineers are working to resolve the issues as quickly as possible.
Posted Dec 07, 2022 - 11:04 EST
Update
We are aware of issues impacting users' ability to log in to blackbaud.com and various solutions. Users may see Error: "Our services aren't available right now," or a continual loading screen. Engineers are working to resolve the issues as quickly as possible.
Posted Dec 07, 2022 - 10:25 EST
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause and we have the appropriate engineers working to get your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Dec 07, 2022 - 10:12 EST
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Dec 07, 2022 - 10:06 EST
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Dec 07, 2022 - 10:00 EST
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Dec 07, 2022 - 09:57 EST
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™), Blackbaud Grantmaking™ (Blackbaud Grantmaking™), Blackbaud.com (Blackbaud.com, signin.blackbaud.com), Blackbaud Fundraiser Performance Management™ (Blackbaud Fundraiser Performance Management™), Blackbaud Altru®, Blackbaud Award Management™, Blackbaud CRM™, Blackbaud eTapestry®, Blackbaud Financial Aid Management™, Blackbaud Guided Fundraising™, Blackbaud Tuition Management™, Email Services, Payment Services, ResearchPoint™, Blackbaud Financial Edge NXT® (Financial Edge NXT), Blackbaud Education Management Solutions (Core Functionality), and Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).