Maintenance Overage 45328 - CRM / Direct Marketing / Blackbaud Internet Solutions
Incident Report for Blackbaud
Resolved
The scheduled maintenance has been completed.
Posted Jan 10, 2020 - 04:17 EST
Identified
Maintenance ID 20010308445328 - The maintenance that was scheduled to complete on 01/10/2020 at 3:00:00 AM EST has been extended to 5:00:00 AM EST.
This maintenance is necessary to Migrate Blackbaud CRM/BBDM/BBIS sites.
Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Jan 10, 2020 - 03:08 EST
This incident affected: Blackbaud CRM™, Blackbaud Internet Solutions™, and Direct Marketing™.