Active Issue Alert – eTapestry - #000307333
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 22, 2021 - 12:17 EST
Investigating
This issue is now resolved. If you continue having issues accessing your solution, please close and then reopen your web browser to be sure everything refreshes.
Posted Nov 22, 2021 - 11:07 EST
This incident affected: eTapestry.