Maintenance Overage 21092808361872 - Blackbaud Netcommunity
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Oct 06, 2021 - 01:01 EDT
Identified
Maintenance ID 21092808361872 - The maintenance that was scheduled to complete on 10/5/2021 at 12:00 AM has been extended to 1:00 AM.

Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Oct 06, 2021 - 00:17 EDT
This incident affected: Blackbaud NetCommunity™.