Active Issue Alert – CSRconnect - #000365810
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jun 13, 2022 - 20:24 EDT
Identified
Our engineers have successfully diagnosed an issue with CSRconnect Reporting and we have the appropriate engineers available working to address it for you. We hope to have your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Jun 13, 2022 - 10:48 EDT
This incident affected: YourCause® (YourCause® CSRconnect®).