Active Issue Alert – Sphere - #2019010801
Incident Report for Blackbaud
Resolved
An issue impacting some of our Sphere customers causing intermittent slowness, errors or other service issues when attempting to login is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 08, 2019 - 12:00 EST
Identified
We have identified an issue impacting some of our Sphere customers. Our engineers are still working to diagnose and remediate the underlying cause of this issue so that access to your services are restored as quickly as possible. Please continue to reference this page for updates.
Posted Jan 08, 2019 - 11:48 EST
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the Sphere application. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jan 08, 2019 - 11:12 EST