Active Issue Alert – Raisers Edge NXT and Raisers Edge - 000267829
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jul 16, 2021 - 12:39 EDT
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Jul 16, 2021 - 12:39 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®) and Raiser's Edge®.