Active Issue Alert – Online Express - 000411616
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 23, 2022 - 15:15 EST
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause and we have the appropriate engineers working to get your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Nov 23, 2022 - 14:58 EST
Update
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Nov 23, 2022 - 14:26 EST
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Nov 23, 2022 - 13:54 EST
This incident affected: Blackbaud Online Express™ (Blackbaud Online Express™).