Active Issue Alert – Blackbaud Merchant Services - #2018111401
Incident Report for Blackbaud
Resolved
An issue impacting a small subset of our customers is now resolved and batch credit card transactions are now processing. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 14, 2018 - 14:37 EST
Monitoring
Our partners have applied a fix to issues that a small subset of Merchant Services are experiencing when processing batch transactions for credit cards. Older jobs are currently completing and we are monitoring for full completion and any new errors. Please continue to reference this page for updates.
Posted Nov 14, 2018 - 13:53 EST
Update
As reported, we are aware that a small subset of our Merchant Services customers are experiencing delays when processing batch transactions for credit cards. Our partners are actively working on the issue to ensure impact is resolved as quickly as possible. Please continue to reference this page for updates.
Posted Nov 14, 2018 - 13:24 EST
Identified
We are aware that a small subset of our Merchant Services customers are experiencing delays when processing batch transactions for credit cards. The issue has be identified with our partners and we are working with them to ensure impact is resolved as quickly as possible. Please continue to reference this page for updates.
Posted Nov 14, 2018 - 12:52 EST
Investigating
We are aware that a small subset of our Merchant Services customers are experiencing delays when processing batch transactions for credit cards. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Nov 14, 2018 - 12:40 EST
This incident affected: Blackbaud Merchant Services™ (Blackbaud Merchant Services™).