Active Issue Alert – Education Edge, Financial Edge, Raiser's Edge - #000148302
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jul 10, 2020 - 12:53 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 10, 2020 - 12:13 EDT
This incident affected: Financial Edge® and Raiser's Edge®.