Active Issue Alert – Raiser's Edge NXT - 000353590
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted May 12, 2022 - 05:08 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted May 12, 2022 - 04:31 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted May 12, 2022 - 02:20 EDT
This incident affected: Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®).