Active Issue Alert – Blackbaud NetCommunity, Financial Edge, Financial Edge NXT - #000287250
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Sep 17, 2021 - 21:04 EDT
Monitoring
By 5pm ET service appears to have been restored for all customers. A fix has been implemented and we are monitoring the results
Posted Sep 17, 2021 - 17:33 EDT
Update
Engineers are still working to determine root cause for this issue. They have explored a series of possibilities thus far. Once root cause is determined, they will implement a fix. We will continue updating this page every half hour until the issue is resolved.
Posted Sep 17, 2021 - 16:36 EDT
Update
Engineers continue their work to determine root cause for this issue. They have explored a series of possibilities thus far. Once root cause is determined, they will implement a fix. We will continue updating this page every half hour until the issue is resolved.
Posted Sep 17, 2021 - 16:01 EDT
Update
Engineers are still working to determine root cause for this issue. They have explored a series of possibilities thus far. Once root cause is determined, they will implement a fix. We will continue updating this page every half hour until the issue is resolved.
Posted Sep 17, 2021 - 15:35 EDT
Update
Engineers continue their work to determine root cause for this issue. They have explored a series of possibilities thus far. Once root cause is determined, they will implement a fix. We will continue updating this page every half hour until the issue is resolved.
Posted Sep 17, 2021 - 15:06 EDT
Update
We are aware of an issue that is affecting customers who use Raiser’s Edge®, Blackbaud Raiser’s Edge NXT®, Financial Edge®, Blackbaud Financial Edge NXT®, Blackbaud Internet Solutions™ and/or Blackbaud NetCommunity™. This appears to be limited to customers who are hosted in the US-East datacenter. If affected, customers may be unable to launch one or more of those specific products. Some customers have reported receiving an “unknown error” message or being directed to the maintenance page instead of their solution. Engineers are working to determine root cause and to implement a permanent fix.
Posted Sep 17, 2021 - 14:54 EDT
Update
We are aware of an issue that is affecting customers who use Raiser’s Edge®, Blackbaud Raiser’s Edge NXT®, Financial Edge®, Blackbaud Financial Edge NXT®, Blackbaud Internet Solutions™ and/or Blackbaud NetCommunity™. This appears to be limited to customers who are hosted in the US-East datacenter. If affected, customers may be unable to launch one or more of those specific products. Some customers have reported receiving an “unknown error” message or being directed to the maintenance page instead of their solution. Engineers are working to determine root cause and to implement a permanent fix.
Posted Sep 17, 2021 - 14:35 EDT
Update
We are aware of an issue that is affecting customers who use Raiser’s Edge®, Blackbaud Raiser’s Edge NXT®, Financial Edge®, Blackbaud Financial Edge NXT®, Blackbaud Internet Solutions™ and/or Blackbaud NetCommunity™. This appears to be limited to customers who are hosted in the US-East datacenter. If affected, customers may be unable to launch one or more of those specific products. Some customers have reported receiving an “unknown error” message or being directed to the maintenance page instead of their solution. Engineers are working to determine root cause and to implement a permanent fix.
Posted Sep 17, 2021 - 14:07 EDT
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Sep 17, 2021 - 13:34 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Sep 17, 2021 - 13:19 EDT
This incident affected: Financial Edge NXT (Financial Edge NXT), Raiser's Edge NXT (Raiser's Edge NXT), and Blackbaud Internet Solutions, Blackbaud NetCommunity, Email Services, Financial Edge.