Active Issue Alert – Financial Edge, Raiser's Edge - Request Entry-000322756
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 24, 2022 - 14:14 EST
Update
We are seeing a delay in the initial loading of the app, once loaded the app is functional like normal. Please allow for this delay before reloading the app. Our engineers have successfully diagnosed the issue and we have the appropriate engineers available working to address it for you. We hope to have your full service restored as quickly as possible. Please continue to reference this page for updates.
Posted Jan 24, 2022 - 13:53 EST
Identified
Our engineers have successfully diagnosed the issue, and we are working to address it now. Please continue to reference this page for updates.
Posted Jan 24, 2022 - 13:24 EST
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jan 24, 2022 - 12:49 EST
This incident affected: Financial Edge® and Raiser's Edge®.