Active Issue Alert – Financial Edge NXT - #2018041401
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 14, 2018 - 15:58 EDT
Investigating
We have identified an issue impacting some of our Financial Edge NXT customers causing errors when attempting to open database view from within the application. This would only affect new users or users who have not opened database view within the last 14 days. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 14, 2018 - 15:45 EDT
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT).