Active Issue Alert – [[FIMS Hostnet]] - #2019041501
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Apr 15, 2019 - 15:23 EDT
Investigating
We have identified an issue impacting some of our customers causing intermittent slowness, errors or other service issues. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 15, 2019 - 13:55 EDT