Active Issue Alert – Blackbaud Analytics - #2019041003
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Apr 10, 2019 - 21:55 EDT
Investigating
We have identified an issue impacting some of our customers causing them to be unable to acces their deliverables. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Apr 10, 2019 - 21:32 EDT
This incident affected: Blackbaud Analytics.