Active Issue Alert – Financial Edge, Financial Edge NXT, Raiser's Edge, Raiser's Edge NXT - #2019020604
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Feb 06, 2019 - 23:43 EST
Investigating
We have identified an issue impacting some of our customers causing slowness in database view. Our engineers have identified a fix and are deploying the fix to the affected services. During this event, connection may be lost and you may be required to log in again. The next update will be provided at 11:30 PM ET.
Posted Feb 06, 2019 - 18:58 EST
This incident affected: Blackbaud Financial Edge NXT® (Financial Edge NXT), Blackbaud Raiser's Edge NXT® (Raiser's Edge NXT®), and Financial Edge®, Raiser's Edge®.