Active Issue Alert – Education Edge, Financial Edge, Raiser's Edge - #2019081401
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted 18 days ago. Sep 03, 2019 - 07:07 EDT
Monitoring
[Applicable to on-premise and self-hosted customers of these solutions only] - Microsoft has released fixes for this issue for:
• Windows 10 TH1 (v1507), RS1 (v1607), RS2 (v1703), RS3 (v1709), RS4 (v1803), RS5 (v1809), and 19H1 (v1903)
• Windows 8.1 and Windows Server 2012 R2
• Windows Server 2012
• Windows 7 and Windows Server 2008 R2 SP1
• Windows Server 2008 SP2

View the Blackbaud KB article: https://kb.blackbaud.com/articles/article/191128 for links to these fixes and how to apply the patch manually. We recommend that customers on the above versions of Windows should quickly apply the corresponding patch and get back to their normal cadence of security patching.

All Microsoft fixes have been released and there are no further updates. We will leave this post up for informational purposes until Sept. 2nd at 5pm ET.
Posted 21 days ago. Aug 30, 2019 - 16:16 EDT
Update
[Applicable to on-premise and self-hosted customers of these solutions only] - Microsoft has released fixes for this issue for:
• Windows 10 TH1 (v1507), RS1 (v1607), RS2 (v1703), RS3 (v1709), RS4 (v1803) and RS5 (v1809)
• Windows 8.1 and Windows Server 2012 R2
• Windows Server 2012
• Windows 7 and Windows Server 2008 R2 SP1
• Windows Server 2008 SP2

View the Blackbaud KB article: https://kb.blackbaud.com/articles/article/191128 for links to these fixes and how to apply the patch manually. We recommend that customers on the above versions of Windows should quickly apply the corresponding patch and get back to their normal cadence of security patching.

Microsoft continues to work on fixes for Windows 10 19H1 (v1903). We will share an update when available.
Posted about 1 month ago. Aug 19, 2019 - 13:10 EDT
Update
[Applicable to on-premise and self-hosted customers of these solutions only] - Microsoft has identified the root cause and is working on the fix. They have updated their KB articles and mentioned this issue as a known issue in KB4512508 (https://support.microsoft.com/en-us/help/4512508/windows-10-update-kb4512508) and in other related KBs listed here: https://docs.microsoft.com/en-us/windows/release-information/status-windows-10-1903.

Until Microsoft has released a fix, we recommend that you do not install the August 13 Windows update. We will communicate when this fix has been released so that you can then apply the patch and get back to your normal cadence of security patching.
Posted about 1 month ago. Aug 15, 2019 - 10:36 EDT
Update
On Tuesday, August 13, Microsoft released an update for Windows including but not limited to KB4512506, KB890830, KB4474419, KB451250 and KB4512486. Following this release, we are aware of an issue impacting on-premise and self-hosted customers that have installed this Microsoft update. Customers may experience the inability to log in to one or all of these solutions. To avoid difficulties logging in to the Blackbaud Solutions listed above, we recommend that customers do not install the August 13 Windows Update on their environments until we have identified and addressed the current issue. For those customers that have updated to this version, we are aware of users having success when uninstalling the update, therefore we recommend taking this action. Please note, however, that not installing or uninstalling the release means customers will not have the protections of the security patching.We will provide an update when we have more information.
Posted about 1 month ago. Aug 14, 2019 - 17:55 EDT
Update
We have identified an issue impacting some of our customers with self hosted installations of Education Edge, Financial Edge, and Raiser's Edge when logging on. Our engineers are still diagnosing the event and working to resolve it for you as quickly as possible.

A workaround can be found here: https://kb.blackbaud.com/articles/article/191128
Posted about 1 month ago. Aug 14, 2019 - 11:24 EDT
Update
We have identified an issue impacting some of our customers with self hosted installations of Education Edge, Financial Edge, and Raiser's Edge when logging on. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible.

A workaround can be found here: https://kb.blackbaud.com/articles/article/191128
Posted about 1 month ago. Aug 14, 2019 - 10:50 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted about 1 month ago. Aug 14, 2019 - 10:33 EDT
This incident affected: Education Edge (Education Edge) and Financial Edge, Raiser's Edge.