Resolved Issue Alert – Raiser's Edge NXT – #2019040801
Incident Report for Blackbaud
Resolved
Earlier today we identified an issue impacting some of our customers loading constituent errors or trying to utilize Database View. Our engineers successfully implemented a fix and services were restored. If you have any questions about status in the future, you can always get updates at this page.
Posted Apr 08, 2019 - 12:00 EDT