Maintenance Overage – Financial Edge, Raisers Edge, Blackbaud Church Management - RFC #20091405492465
Incident Report for Blackbaud
Resolved
The work has now been completed successfully. We apologize for any inconvenience this may have caused.
Posted Oct 17, 2020 - 21:05 EDT
Investigating
We are currently experiencing an overage concerning RFC#20091405492465 that is affecting small subset of customers. Our engineers are working to complete this work for you as quickly as possible. Please continue to reference this page for updates.
Posted Oct 17, 2020 - 18:29 EDT
This incident affected: Financial Edge® and Raiser's Edge®.