Maintenance Overage 21082301200529- Blackbaud NetCommunity
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Sep 15, 2021 - 05:54 EDT
Identified
Maintenance ID 21082301200529- The maintenance that was scheduled to complete on 9/15/2021 at 3:00:00 AM has been extended to 5:00:00 AM

Please refer to this page for updates on the completion or additional extensions of the maintenance.
Posted Sep 15, 2021 - 02:50 EDT
This incident affected: Blackbaud NetCommunity™.