Active Issue Alert –Blackbaud Award Management - #000219606
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Feb 16, 2021 - 09:29 EST
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Feb 16, 2021 - 09:17 EST
This incident affected: Blackbaud Award Management™.