Active Issue Alert – ResearchPoint - 000305748
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Nov 17, 2021 - 14:11 EST
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates. The next update will be 3:00 PM EST.
Posted Nov 17, 2021 - 13:40 EST
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates. The next update will be 2:00 PM EST.
Posted Nov 17, 2021 - 12:20 EST
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates. The next update will be 12 PM EST tomorrow 11/17/2021.
Posted Nov 16, 2021 - 13:57 EST
Update
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates. The next update will be at 1:30 PM EST.
Posted Nov 16, 2021 - 12:21 EST
Investigating
We have identified an issue impacting some of our customers. Our engineers are still working to diagnose the cause so that they can resolve it as quickly as possible for you. Please continue to reference this page for updates.
Posted Nov 16, 2021 - 11:56 EST
This incident affected: ResearchPoint™.