Active Issue Alert – Raiser's Edge NXT - #000153102
Incident Report for Blackbaud
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 15:13 EDT
Update
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 24, 2020 - 13:25 EDT
Identified
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 24, 2020 - 12:52 EDT
Investigating
We have identified an issue impacting some of our customers causing errors when attempting to log in or use features within the affected service. Our engineers are diagnosing the event and working to resolve it for you as quickly as possible. Please continue to reference this page for updates.
Posted Jul 24, 2020 - 12:20 EDT
This incident affected: Raiser's Edge NXT (Raiser's Edge NXT).