Active Issue Alert – Financial Edge, Raiser's Edge - Request Entry-000322756
Incident Report for Blackbaud
Resolved
An issue impacting some of our customers causing intermittent slowness, errors or other service issues is now resolved and services have been restored. If you have any questions about status in the future, you can always get updates at this page. Thank you.
Posted Jan 25, 2022 - 14:42 EST
Monitoring
We have identified the root cause of the delay in the initial loading of the app and are working on the fix. In the meantime, when you attempt to login to your app you may notice a delay where the splash screen disappears. Please wait 3-5 seconds after the splash screen disappears and you should be able to login as normal. Once loaded the app is functioning as normal. Please continue to reference this page for updates. Next scheduled update will be on 01/25/2022 at 1:30 PM EST.
Posted Jan 24, 2022 - 15:47 EST
This incident affected: Financial Edge® and Raiser's Edge®.