Resolved Issue Alert – Financial Edge NXT and Raiser's Edge NXT – #2018051602
Incident Report for Blackbaud
Resolved
Earlier today we identified an issue impacting a small subset of our customers unable to navigate using the Omnibar. Our engineers have successfully implemented a fix and services are now restored. If you have any questions about status in the future, you can always get updates at this page.
Posted May 16, 2018 - 12:00 EDT